Jump to content


Caska GPS / DVD unit in Mazda 5 - indicators not working / handbrake

  • Please log in to reply
No replies to this topic

#1 danatoakhill



  • Feedback: View
  • PipPip
  • 12 posts

Posted 03 Mar 2012 - 10:48

Hi all,

If anyone could help it'd stop me going mad...

I installed a gps/DVD stereo in my Mazda 5 a few months ago and it worked well, but I then realised that it didn't include all the features that were advertised (RDS to name one) so I sent it back for a refund. I then bought a slightly different one (found a better deal on the OEM one) and installed it, however when I plug in the main wiring harness and start the car, the trip computer stops working (I know this is sometimes the case but work around would be appreciated) but more worrying the indicators stop working and the handbrake light is stuck on.

Here's a summary of the wiring - basically, I got the unit cheap as it had been used as a display unit. This meant that the yellow, red and brown wires on the main harness had been cut in order to hook it up in a different way. I reconnected each of these. The only othe change I made was to connect the 'back/reverse wire to the power on my reverse camera so that reverse gear triggers the reverse camera)

Have I connected up the wires wrongly (even though they're just connected where they'd been cut? I I'm guessing the yellow is constant and red is switched as when I connect the yellow the unit doesn't power off when the ignition goes off. Is the brown ground then?

Last thing to say is that I noticed that one of the contacts inside the main socket on the wiring harness had bent... Couldn't be sure it was making contact properly with the main socket in the car. (thin green wire). So to be sure they connected I used wired connectors to run a wire intersecting with the green wire over to the wire it should have been connecting to on the car main harness then plugged the socket it. Nothing changed. But I'm not actually sure that it should have worked!

Any help with this would be great... I'm pretty stuck!

See attached pictures of wire harness that came with the unit. I've disconnected the three wires so they're as they were when it came.





Sorry, these might work...